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A Tabbed Document windows  B Application bar  C Workspace switcher  D Panel title bar  E Control panel  F Tools panel  G Collapse To Icons 
button  H Four panel groups in vertical dock  
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You use tools in the Tools panel to create, select, and manipulate objects in Illustrator. Some tools have options that 
appear when you double-click a tool. These include tools that let you use type, and select, paint, draw, sample, edit, and 
move images. 

You can expand some tools to show hidden tools beneath them. A small triangle at the lower-right corner of the tool 
icon signals the presence of hidden tools. To see the name of a tool, position the pointer over it. 

You can also use the Tools panel to change the drawing mode from Draw Normal to Draw Behind or Draw Inside. 

View hidden tools
Hold down the mouse button on the visible tool.
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Change tool pointers
The mouse pointer for most tools matches the tool’s icon. Each pointer has a different hotspot, where an effect or action 
begins. With most tools, you can switch to precise cursors, which appear as cross hairs centered around the hotspot, 
and provide for greater accuracy when working with detailed artwork.

Choose Edit > Preferences > General (Windows) or Illustrator > Preferences > General (Mac OS), and select Use 
Precise Cursors. Alternatively, press Caps Lock on the keyboard.

More Help topics 
Tool galleries

Tool galleries
Illustrator provides many tools for creating and manipulating your artwork. These galleries provide a quick visual 
overview for each tool.

Selection tool gallery
Illustrator provides the following selection tools:

The Selection tool (V) selects entire 
objects. See Select objects with the 
Selection tool.

The Direct Selection tool (A) selects 
points or path segments within 
objects. See .

The Group Selection tool selects 
objects and groups within groups. 
See Select objects and groups with 
the Group Selection tool.

The Magic Wand tool (Y) selects 
objects with similar attributes. See 
Select objects with the Magic Wand 
tool.

The Lasso tool (Q) selects points or 
path segments within objects. See 
Select objects with the Lasso tool.

The Artboard tool creates separate 
artboards for printing or export. 
See Create an artboard.

http://helpx.adobe.com/en/illustrator/using/tool-galleries.html#tool_galleries
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Drawing tool gallery
Illustrator provides the following drawing tools:

The Pen tool (P) draws straight and 
curved lines to create objects. See 
Draw with the Pen tool.

The Add Anchor Point tool (+) adds 
anchor points to paths. See .

The Delete Anchor Point tool (-) 
deletes anchor points from paths. 
See .

The Convert Anchor Point tool 
(Shift+C) changes smooth points to 
corner points and vice versa. See .

The Line Segment tool (\) draws 
individual straight line segments. 
See .

The Arc tool draws individual 
concave or convex curve segments. 
See .

The Spiral tool draws clockwise and 
counterclockwise spirals. See .

The Rectangular Grid tool draws 
rectangular grids. See .
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Type tool gallery
Illustrator provides the following type tools:

The Polar Grid tool draws circular 
chart grids. See .

The Rectangle tool (M) draws 
squares and rectangles. See .

The Rounded Rectangle tool draws 
squares and rectangles with 
rounded corners. See .

The Ellipse tool (L) draws circles and 
ovals. See .

The Polygon tool draws regular, 
multi-sided shapes. See .

The Star tool draws stars. See . The Flare tool creates lens-flare or 
solar-flare-like effects. See Draw 
flares.

The Pencil tool (N) draws and edits 
freehand lines. See Draw with the 
Pencil tool.

The Smooth tool smooths Bezier 
paths. See .

The Path Eraser tool erases paths 
and anchor points from the object. 
See .

The Perspective Grid allows 
creating and rendering artwork in 
perspective. See About Perspective 
Grid.

The Perspective Selection tool 
allows you to bring objects, text, 
and symbols in perspective, move 
objects in perspective, move objects 
in perpendicular to its current 
direction. See About Perspective 
Grid..

http://helpx.adobe.com/illustrator/using/perspective-grid.html
http://helpx.adobe.com/illustrator/using/perspective-grid.html
http://helpx.adobe.com/illustrator/using/perspective-grid.html
http://helpx.adobe.com/illustrator/using/perspective-grid.html
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Painting tool gallery
Illustrator provides the following painting tools:

The Type tool (T) creates individual 
type and type containers and lets 
you enter and edit type. See Enter 
text in an area.

The Area Type tool changes closed 
paths to type containers and lets 
you enter and edit type within 
them. See Enter text in an area.

The Type On A Path tool changes 
paths to type paths, and lets you 
enter and edit type on them. See 
Creating type on a path .

The Vertical Type tool creates 
vertical type and vertical type 
containers and lets you enter and 
edit vertical type. See Enter text in 
an area.

The Vertical Area Type tool changes 
closed paths to vertical type 
containers and lets you enter and 
edit type within them. See Enter text 
in an area.

The Vertical Type On A Path tool 
changes paths to vertical type 
paths and lets you enter and edit 
type on them. See Creating type on 
a path .

http://helpx.adobe.com/en/illustrator/using/creating-type-path.html#creating_type_on_a_path
http://helpx.adobe.com/en/illustrator/using/creating-type-path.html#creating_type_on_a_path
http://helpx.adobe.com/en/illustrator/using/creating-type-path.html#creating_type_on_a_path
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Reshaping tool gallery
Illustrator provides the following tools for reshaping objects:

The Paintbrush tool (B) draws 
freehand and calligraphic lines, as 
well as art, patterns, and bristle 
brush strokes on paths. See Draw 
paths and apply brush strokes 
simultaneously.

The Mesh tool (U) creates and edits 
meshes and mesh envelopes. See 
Create mesh objects.

The Gradient tool (G) adjusts the 
beginning and ending points and 
angle of gradients within objects, or 
applies a gradient to objects. See 
Apply a gradient to an object.

The Eyedropper tool (I) samples and 
applies color, type, and appearance 
attributes, including effects, from 
objects. See Copy appearance 
attributes using the Eyedropper 
tool.

The Live Paint Bucket tool (K) paints 
faces and edges of Live Paint 
groups with the current paint 
attributes. See Paint with the Live 
Paint Bucket tool.

The Live Paint Selection (Shift-
L)tool selects faces and edges 
within Live Paint groups. See Select 
items in Live Paint groups.

The Measure tool measures the 
distance between two points. See 
Measure the distance between 
objects .

The Blob Brush tool (Shift-B)draws 
paths that automatically expand 
and merge calligraphic brush paths 
that share the same color and are 
adjacent in stacking order. See .

http://helpx.adobe.com/illustrator/using/apply-or-edit-gradient.html
http://helpx.adobe.com/en/illustrator/using/rulers-grids-guides-crop-marks.html#measure_the_distance_between_objects
http://helpx.adobe.com/en/illustrator/using/rulers-grids-guides-crop-marks.html#measure_the_distance_between_objects
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The Rotate tool (R) rotates objects 
around a fixed point. See Rotate 
objects.

The Reflect tool (O) flips objects over 
a fixed axis. See Reflect or flip 
objects.

The Scale tool (S) resizes objects 
around a fixed point. See .

The Shear tool skews objects 
around a fixed point. See .
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Chapter 5: Drawing

Drawing basics

Is ideating, tracing, or prototyping on your iPad or iPhone the beginning of your Design workflow?

Check out Adobe Illustrator Draw - an app for your iPad or iPhone. Draw incorporates your favorite vector drawing 
tools and features into a streamlined, modern interface. You can draw lines, shapes, and freeform illustrations and with 
ten drawing layers and a photo layer. And when you’re back at your desk, Creative Cloud connectivity makes it easy to 
apply finishing touches in Illustrator CC or Photoshop CC.

Learn more about the Adobe Illustrator Draw app here.

Download the amazing Adobe Illustrator Draw app from the iTunes app store (Available for your iPhone and iPad).

About vector graphics
Vector graphics (sometimes called vector shapes or vector objects) are made up of lines and curves defined by 
mathematical objects called vectors, which describe an image according to its geometric characteristics.

You can freely move or modify vector graphics without losing detail or clarity, because they are resolution-
independent—they maintain crisp edges when resized, printed to a PostScript printer, saved in a PDF file, or imported 
into a vector-based graphics application. As a result, vector graphics are the best choice for artwork, such as logos, that 
will be used at various sizes and in various output media. 

The vector objects you create using the drawing and shape tools in Adobe Creative Suite are examples of vector 
graphics. You can use the Copy and Paste commands to duplicate vector graphics betweenCreative Suite components.

https://helpx.adobe.com/content/help/en/mobile-apps/how-to/illustrator-draw-get-started.html
http://www.adobe.com/go/draw_itunes
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About paths
As you draw, you create a line called a path. A path is made up of one or more straight or curved segments. The 
beginning and end of each segment are marked by anchor points, which work like pins holding a wire in place. A path 
can be closed (for example, a circle), or open, with distinct endpoints (for example, a wavy line).

You change the shape of a path by dragging its anchor points, the direction points at the end of direction lines that appear 
at anchor points, or the path segment itself.

A Selected (solid) endpoint  B Selected anchor point  C Unselected anchor point  D Curved path segment  E Direction line  F Direction point  

Paths can have two kinds of anchor points: corner points and smooth points. At a corner point, a path abruptly changes 
direction. At a smooth point, path segments are connected as a continuous curve. You can draw a path using any 
combination of corner and smooth points. If you draw the wrong kind of point, you can always change it.

A Four corner points  B Four smooth points  C Combination of corner and smooth points  

A corner point can connect any two straight or curved segments, while a smooth point always connects two curved 
segments.

Note: Don’t confuse corner and smooth points with straight and curved segments.

A path’s outline is called a stroke. A color or gradient applied to an open or closed path’s interior area is called a fill. A 
stroke can have weight (thickness), color, and a dash pattern (Illustrator and InDesign) or a stylized line pattern 
(InDesign). After you create a path or shape, you can change the characteristics of its stroke and fill.

In InDesign, each path also displays a center point, which marks the center of the shape but is not part of the actual path. 
You can use this point to drag the path, to align the path with other elements, or to select all anchor points on the path. 
The center point is always visible; it can’t be hidden or deleted.
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About direction lines and direction points
When you select an anchor point that connects curved segments (or select the segment itself), the anchor points of the 
connecting segments display direction handles, which consist of direction lines that end in direction points. The angle 
and length of the direction lines determine the shape and size of the curved segments. Moving the direction points 
reshapes the curves. Direction lines don’t appear in the final output.

A smooth point always has two direction lines, which move together as a single, straight unit. When you move a 
direction line on a smooth point, the curved segments on both sides of the point are adjusted simultaneously, 
maintaining a continuous curve at that anchor point.

In comparison, a corner point can have two, one, or no direction lines, depending on whether it joins two, one, or no 
curved segments, respectively. Corner point direction lines maintain the corner by using different angles. When you 
move a direction line on a corner point, only the curve on the same side of the point as that direction line is adjusted.

Direction lines are always tangent to (perpendicular to the radius of) the curve at the anchor points. The angle of each 
direction line determines the slope of the curve, and the length of each direction line determines the height, or depth, 
of the curve.

Note: In Illustrator, you can show or hide anchor points, direction lines, and direction points by choosing View > Show 
Edges or View > Hide Edges. 
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• To create an S-shaped curve, drag in the same direction as the previous direction line. Then release the mouse
button.

(Photoshop only) To change the direction of the curve sharply, release the mouse button, and then Alt-drag 
(Windows) or Option-drag (Mac OS) the direction point in the direction of the curve. Release the Alt (Windows) or 

Option (Mac OS) key and the mouse button, reposition the pointer where you want the segment to end, and drag in the 
opposite direction to complete the curve segment.

5 Continue dragging the Pen tool from different locations to create a series of smooth curves. Note that you are 
placing anchor points at the beginning and end of each curve, not at the tip of the curve.

Alt-drag (Windows) or Option-drag (Mac OS) direction lines to break out the direction lines of an anchor point. 

6 Complete the path by doing one of the following:

• To close the path, position the Pen tool over the first (hollow) anchor point. A small circle appears next to the
Pen tool pointer when it is positioned correctly. Click or drag to close the path.

note: To close a path in InDesign, you can also select the object and choose Object > Paths > Close Path.

• To leave the path open, Ctrl-click (Windows) or Command-click (Mac OS) anywhere away from all objects.

To leave the path open, you can also select a different tool, or choose Select > Deselect in Illustrator or Edit
>Deselect All in InDesign.

Reposition anchor points as you draw
After you click to create an anchor point, keep the mouse button pressed down, hold down the spacebar, and drag 
to reposition the anchor point.
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Finish drawing a path
Complete a path in one of the following ways:

• To close a path, position the Pen tool over the first (hollow) anchor point. A small circle appears next to the Pen 
tool pointer when it is positioned correctly. Click or drag to close the path.

Note: To close a path in InDesign, you can also select the object and choose Object > Paths > Close Path.

• To leave a path open, Ctrl-click (Windows) or Command-click (Mac OS) anywhere away from all objects.

To leave the path open, you can also select a different tool, or choose Select > Deselect in Illustrator or Edit > Deselect 
All in InDesign. In InDesign, you can also simply press Enter or Return to leave the path open.

Draw straight lines followed by curves
1 Using the Pen tool, click corner points in two locations to create a straight segment.

2 Position the Pen tool over the selected endpoint. In Illustrator and InDesign, a convert-point icon appears next to 
the Pen tool when it is positioned correctly (In Photoshop, a small diagonal line, or slash, appears next to the Pen 
tool). To set the slope of the curved segment you’ll create next, click the anchor point, and drag the direction line 
that appears.

A Straight segment completed  B Positioning Pen tool over endpoint (the Convert Point icon appears only in Illustrator and InDesign)  
C Dragging direction point  

3 Position the pen where you want the next anchor point; then click (and drag, if desired) the new anchor point to 
complete the curve.

A Positioning Pen tool  B Dragging direction line  C New curve segment completed  

Draw curves followed by straight lines
1 Using the Pen tool, drag to create the first smooth point of the curved segment, and release the mouse button.

2 Reposition the Pen tool where you want the curved segment to end, drag to complete the curve, and release the 
mouse button.
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A First smooth point of curved segment completed and Pen tool positioned over endpoint  B Dragging to complete the curve  

3 Position the Pen tool over the selected endpoint. A convert-point icon appears next to the Pen tool when it is 
positioned correctly. Click the anchor point to convert the smooth point to a corner point.

4 Reposition the Pen tool where you want the straight segment to end, and click to complete the straight segment.

A Positioning Pen tool over existing endpoint  B Clicking endpoint  C Clicking next corner point  

Draw two curved segments connected by a corner
1 Using the Pen tool, drag to create the first smooth point of a curved segment.

2 Reposition the Pen tool and drag to create a curve with a second smooth point; then press and hold Alt (Windows) 
or Option (Mac OS) and drag the direction line toward its opposing end to set the slope of the next curve. Release 
the key and the mouse button.

This process converts the smooth point to a corner point by splitting the direction lines.

3 Reposition the Pen tool where you want the second curved segment to end, and drag a new smooth point to 
complete the second curved segment.

A Dragging a new smooth point  B Pressing Alt/Option to split direction lines while dragging, and swinging direction line up  C Result after 
repositioning and dragging a third time  

More Help topics 
Video tutorial - Pen tool preview

https://helpx.adobe.com/illustrator/how-to/new-pen-tool.html
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Enhanced Pencil Tool
The Pencil Tool has been improved to facilitate better curve-fitting, auto-closing of paths, and drawing of constrained 
and unconstrained straight line segments.

Pencil Tool
Presets

Double-click the Pencil Tool icon in the Toolbox to open the Pencil Tool Options dialog. The Fidelity slider has four 
presets you can choose from. The leftmost slider preset (Accurate) is most accurate for drawing paths. The rightmost 
slider preset (Smooth) creates the smoothest paths. Choose a preset that suits your drawing needs best.

Additional Fidelity preset (Introduced in the 2014 release of Illustrator CC)

The Fidelity slider has 5 presets from Illustrator CC 2014. A new slider preset (most accurate preset) has been added to 
help you draw the most accurate path possible. Other dialogs that have the additional preset are the Smooth tool, Brush 
tool, and Blob Brush tool dialogs.

Alt key toggles to Smooth Tool option(Introduced in the 2014 release of Illustrator CC)

With this checkbox enabled, while using the Pencil tool or the Brush tool, you can press Alt (Mac: Option) to switch to 
the Smooth tool.

Auto-closing paths

When the endpoints of a path you are drawing are in close proximity and within a certain predefined number of pixels 
of each other, the path-close cursor ( ) is shown. When you release the mouse button, such a path is closed 
automatically.

The predefined number of pixels is set in the Pencil Tool Options dialog box > Within field. 

Drawing constrained or unconstrained straight segments
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Chapter 6: Color

About color
Applying colors to artwork is a common Adobe Illustrator task, and one that requires some knowledge of color models 
and color modes. When applying color to artwork, keep in mind the final medium in which the artwork will be 
published, so that you can use the correct color model and color definitions. Experimenting and applying color is easy 
using the feature-rich Swatches panel, Color Guide panel, and Edit Colors/Recolor Artwork dialog box in Illustrator.

Color models describe the colors we see and work with in digital graphics. Each color model, such as RGB, CMYK, or 
HSB, represents a different method for describing and classifying color. Color models use numeric values to represent 
the visible spectrum of color. A color space is a variant of a color model and has a specific gamut (range) of colors. For 
example, within the RGB color model are a number of color spaces: Adobe® RGB, sRGB, and Apple® RGB. While each 
of these color spaces defines color using the same three axes (R, G, and B), their gamuts are different.

About colors in digital graphics
We use color models to describe the colors we see and work with in digital graphics. Each color model, such as RGB, 
CMYK, or HSB, represents a different method for describing and classifying color. Color models use numeric values to 
represent the visible spectrum of color. A color space is a variant of a color model and has a specific gamut (range) of 
colors. For example, within the RGB color model are a number of color spaces: Adobe® RGB, sRGB, and Apple® RGB. 
While each of these color spaces defines color using the same three axes (R, G, and B), their gamuts are different.

When you work with the colors in a graphic, you are actually adjusting numerical values in the file. It’s easy to think of 
a number as a color, but these numerical values are not absolute colors in themselves—they only have a color meaning 
within the color space of the device that is producing the color.

Because each device has its own color space, it can reproduce colors only in its gamut. When an image moves from one 
device to another, image colors may change because each device interprets the RGB or CMYK values according to its 
own color space. For example, it is impossible for all the colors viewed on a monitor to be identically matched in a print 
from a desktop printer. A printer operates in a CMYK color space, and a monitor operates in an RGB color space. Their 
gamuts are different. Some colors produced by inks cannot be displayed on a monitor, and some colors that can be 
displayed on a monitor cannot be reproduced using inks on paper. 

Even though it is impossible to perfectly match all colors on different devices, you can use color management to ensure 
that most colors are the same or similar enough so they appear consistent.

More Help topics 
About color management in Adobe applications

Synchronize color settings across Adobe applications

RGB, CMYK, HSB, and Lab color models
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RGB
A large percentage of the visible spectrum can be represented by mixing red, green, and blue (RGB) colored light in 
various proportions and intensities. Where the colors overlap, they create cyan, magenta, and yellow.

RGB colors are called additive colors because you create white by adding R, G, and B together—that is, all light is 
reflected back to the eye. Additive colors are used for lighting, television, and computer monitors. Your monitor, for 
example, creates color by emitting light through red, green, and blue phosphors.

A Red  B Green  C Blue  

You can work with color values using the RGB color mode, which is based on the RGB color model. In RGB mode, each 
of the RGB components can use a value ranging from 0 (black) to 255 (white). For example, a bright red color might 
have an R value of 246, a G value of 20, and a B value of 50. When the values of all three components are equal, the result 
is a shade of gray. When the value of all components is 255, the result is pure white; when all components have values 
of 0, the result is pure black.

Illustrator also includes a modified RGB color mode called Web Safe RGB, which includes only those RGB colors that 
are appropriate for use on the web.

More Help topics 
Change the color mode of a document

CMYK
Whereas the RGB model depends on a light source to create color, the CMYK model is based on the light-absorbing 
quality of ink printed on paper. As white light strikes translucent inks, a portion of the spectrum is absorbed. Color that 
is not absorbed is reflected back to your eye.

Combining pure cyan (C), magenta (M), and yellow (Y) pigments would result in black by absorbing, or subtracting, 
all colors. For this reason they are called subtractive colors. Black (K) ink is added for better shadow density. (The letter 
K came into use because black is the “key” color for registering other colors, and because the letter B also stands for 
blue.) Combining these inks to reproduce color is called four-color process printing.

http://helpx.adobe.com/en/illustrator/using/adjusting-colors.html#change_the_color_mode_of_a_document
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A Cyan  B Magenta  C Yellow  D Black  

You can work with color values using the CMYK color mode, which is based on the CMYK color model. In CMYK 
mode, each of the CMYK process inks can use a value ranging from 0 to 100%. The lightest colors are assigned small 
percentages of process ink colors; darker colors have higher percentage values. For example, a bright red might contain 
2% cyan, 93% magenta, 90% yellow, and 0% black. In CMYK objects, low ink percentages are closer to white, and high 
ink percentages are closer to black.

Use CMYK when preparing a document to be printed using process inks.

More Help topics 
Change the color mode of a document

HSB
Based on the human perception of color, the HSB model describes three fundamental characteristics of color:

Hue Color reflected from or transmitted through an object. It is measured as a location on the standard color wheel, 
expressed as a degree between 0° and 360°. In common use, hue is identified by the name of the color, such as red, 
orange, or green. 

Saturation Strength or purity of the color (sometimes called chroma). Saturation represents the amount of gray in 
proportion to the hue, measured as a percentage from 0% (gray) to 100% (fully saturated). On the standard color wheel, 
saturation increases from the center to the edge.

Brightness Relative lightness or darkness of the color, usually measured as a percentage from 0% (black) to 100% 
(white).

A Hue  B Saturation  C Brightness  

More Help topics 
Adjust the saturation of multiple colors

http://helpx.adobe.com/en/illustrator/using/adjusting-colors.html#change_the_color_mode_of_a_document
http://helpx.adobe.com/en/illustrator/using/adjusting-colors.html#adjust_the_saturation_of_multiple_colors
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Lab
The CIE Lab color model is based on the human perception of color. It is one of several color models produced by the 
Commission Internationale d’Eclairage (CIE), an organization dedicated to creating standards for all aspects of light. 

The numeric values in Lab describe all the colors that a person with normal vision sees. Because Lab describes how a 
color looks rather than how much of a particular colorant is needed for a device (such as a monitor, desktop printer, or 
digital camera) to produce colors, Lab is considered to be a device-independent color model. Color management 
systems use Lab as a color reference to predictably transform a color from one color space to another color space. 

In Illustrator, you can use the Lab model to create, display, and output spot color swatches. However, you cannot create 
documents in Lab mode.

More Help topics 
Display and output spot colors using Lab values

Grayscale
Grayscale uses tints of black to represent an object. Every grayscale object has a brightness value ranging from 0% 
(white) to 100% (black). Images produced using black-and-white or grayscale scanners are typically displayed in 
grayscale.

Grayscale also lets you convert color artwork to high-quality black-and-white artwork. In this case, Adobe Illustrator 
discards all color information in the original artwork; the gray levels (shades) of the converted objects represent the 
luminosity of the original objects. 

When you convert grayscale objects to RGB, the color values for each object are assigned that object’s previous gray 
value. You can also convert a grayscale object to a CMYK object.

More Help topics 
Convert color to grayscale and vice versa

Color spaces and gamuts
A color space is a range of colors in the visible spectrum. A color space can also be a variant of a color model. Adobe 
RGB, Apple RGB, and sRGB are examples of different color spaces based on the same color model. 

A Visual gamut  B RGB color space  C CMYK color space  

http://helpx.adobe.com/en/illustrator/using/adjusting-colors.html#display_and_output_spot_colors_using_lab_values
http://helpx.adobe.com/en/illustrator/using/adjusting-colors.html#convert_color_to_grayscale_and_vice_versa
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Color panel overview
You use the Color panel (Window > Color) to apply color to an object’s fill and stroke, and also to edit and mix colors. 
The Color panel can display color values using different color models. By default, only the most commonly used 
options are visible in the Color panel.

A Fill color  B Stroke color  C panel menu  D None box  E Color spectrum bar  F Color slider  G Text box for a color component  

More Help topics 
About colors in digital graphics

Change the color model
Select Grayscale, RGB, HSB, CMYK, or Web Safe RGB from the panel menu. 

Show all options in the panel
? Select Show Options from the panel menu. Alternatively, click the double triangle on the panel’s tab to cycle through 

the display sizes.

Select colors using the Color panel
1 Select the color mode you want to use from the panel menu. The mode you select affects only the display of the Color 

panel; it does not change the color mode of the document.

2 Do one of the following:

• Drag or click in a slider.

• Shift-drag a color slider to move the other sliders in relation to it (except for HSB sliders). This keeps a similar
color but with a different tint or intensity.

• Enter values in any of the text boxes.

• Click in the color spectrum bar at the bottom of the panel. To select no color, click the None box at the left of the 
color bar; to select white, click the white swatch at the upper-right corner of the color bar; to select black, click
the black swatch at the lower-right corner of the color bar.

More Help topics 
About color

Using and creating swatches

Color groups (harmonies)

Adjusting colors

http://helpx.adobe.com/en/illustrator/using/color.html#about_colors_in_digital_graphics
http://helpx.adobe.com/en/illustrator/using/color.html#about_color
http://helpx.adobe.com/en/illustrator/using/using-creating-swatches.html#using_and_creating_swatches
http://helpx.adobe.com/en/illustrator/using/color-groups-harmonies.html#color_groups_harmonies
http://helpx.adobe.com/en/illustrator/using/adjusting-colors.html#adjusting_colors
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Use and create swatches

About swatches
Swatches are named colors, tints, gradients, and patterns. The swatches associated with a document appear in the 
Swatches panel. Swatches can appear individually or in groups. 

You can open libraries of swatches from other Illustrator documents and various color systems. Swatch libraries appear 
in separate panels and are not saved with the document.

The Swatches panel and swatch library panels can contain the following types of swatches:

Process colors A process color is printed using a combination of the four standard process inks: cyan, magenta, yellow, 
and black. By default, Illustrator defines new swatches as process colors. 

Global process colors A global color is automatically updated throughout your artwork when you edit it. All spot colors 
are global; however, process colors can be either global or local. You can identify global color swatches by the global 
color icon (when the panel is in list view) or a triangle in the lower corner (when the panel is in thumbnail view).

Spot colors A spot color is a premixed ink that is used instead of, or in addition to, CMYK process inks. You can 
identify spot-color swatches by the spot-color icon (when the panel is in list view) or a dot in the lower corner (when 
the panel is in thumbnail view). 

Gradients A gradient is a graduated blend between two or more colors or tints of the same color or different colors. 
Gradient colors can be assigned as CMYK process colors, RGB colors, or a spot color. Transparency applied to a 
gradient stop, is preserved when the gradient is saved as a gradient swatch. The aspect-ratio and angle values of elliptical 
gradients (those created by adjusting the aspect ratio or angle of a radial gradient) are not saved.

Patterns Patterns are repeating (tiled) paths, compound paths, text with solid fills or no fill. 

None The None swatch removes the stroke or fill from an object. You can’t edit or remove this swatch.

Registration The registration swatch is a built-in swatch that causes objects filled or stroked with it to print on every 
separation from a PostScript printer. For example, registration marks use the Registration color so that printing plates 
can be aligned precisely on a press. You can’t remove this swatch.

note: If you use the Registration color for type, and then you separate the file and print it, the type may not register properly 
and the black ink may appear muddy. To avoid this, use black ink for type.

Color groups Color groups can contain process, spot, and global process colors. They cannot contain pattern, gradient, 
none, or registration swatches. You create color groups based on harmonies by using either the Color Guide panel or 
the Edit Colors/Recolor Artwork dialog box. To put existing swatches into a color group, select the swatches and click 
the New Color Group icon in the Swatches panel. You can identify a color group by the folder icon .

You can also create tints in the Swatches panel. A tint is a global process color or spot color with a modified intensity. 
Tints of the same color are linked together, so that if you edit the color of a tint swatch, all associated tint swatches (and 
the objects painted with those swatches) change color, though the tint values remain unchanged. Tints are identified by 
a percentage (when the Swatches panel is in list view)

Swatches panel overview
You use the Swatches panel (Window > Swatches) to control all document colors, gradients, and patterns. You can name 
and store any of these items for instant access. When a selected object’s fill or stroke contains a color, gradient, pattern, 
or tint applied from the Swatches panel, the applied swatch is highlighted in the Swatches panel.
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A Spot color  B Global color  C Fill or stroke of None  D Registration swatch (prints on all plates)  E CMYK symbol (when document is open in 
CMYK mode)  F RGB symbol (when document is open in RGB mode)  G Swatch Library Menu button  H Show Swatch Kinds Menu button  
I Swatch Options button  J New ColorGroup button  K New Swatch button  

Change the display of swatches
Select a view option from the Swatches panel menu: Small Thumbnail View, Medium Thumbnail View, Large 
Thumbnail View, Small List View, or Large List View.

Show a specific type of swatch and hide all others
Click the Show Swatch Kinds button and choose one of the following: Show All Swatches, Show Color 
Swatches, Show Gradient Swatches, Show Pattern Swatches, or Show Color Groups.
Select all swatches that aren’t used in artwork
If you want to limit your Swatches panel to only the colors that are used in a document, you can select all unused 
swatches and then delete them. Choose Select All Unused in the Swatches panel menu.

Select a color group

• To select the entire group, click the color group icon .

• To select swatches inside the group, click individual swatches.

Note: To edit the selected color group, make sure no artwork is selected and click the Edit Color Group button , or 
double-click the color group folder. To edit the selected color group and apply the edits to selected artwork, click the Edit Or 
Apply Colors button , or double-click the color group folder. For more information, see Edit colors in the Edit Colors 
dialog box.

Select a swatch by name
Select Show Find Field from the Swatches panel menu. Type the first letter or letters of the swatch’s name in the Find 
text box at the top of the panel. 

Note: This procedure does not work with double-byte characters.

You can also use this method to select a PANTONE® swatch by entering the PANTONE number.

Move swatches into a color group
1 Drag individual color swatches to an existing color group folder.

2 Select the colors you want in a new color group and click the New Color Group button .
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More Help topics 
Group swatches

Create color themes with Kuler

Color Guide panel overview
Use the Color Guide panel as a tool for color inspiration while you create your artwork. The Color Guide panel suggests 
harmonious colors based on the current color in the Tools panel. You can use these colors to color artwork, or you can 
edit them in the Edit Colors/Recolor Artwork dialog box, or save them as swatches or swatch groups in the Swatches 
panel.

You can manipulate the colors that the Color Guide panel generates in several ways, including changing the harmony 
rule, or adjusting the variation type (such as tints and shades or vivid and muted), and the number of variation colors 
that appear. Note: If you have artwork selected, clicking a color variation changes the color of the selected artwork, just like 
clicking a swatch in the Swatches panel.

A Harmony Rules menu and active color group  B Set as base color  C Active colors  D Color variations  E Limits colors to specified swatch library  
F Edit Colors or Edit Or Apply Colors depending on selection (opens the colors in the Edit Colors/Recolor Artwork dialog box)  G Save group to 
Swatches panel  

Note: To edit the selected color group, make sure that no artwork is selected and click the Edit Colors button . To edit 
the selected color group and apply the edits to selected artwork, click the Edit Or Apply Colors button . For more 
information, see Edit colors in the Edit Colors dialog box.

For a video on using the Color Guide to find and create color solutions, see www.adobe.com/go/vid0058.

Specify the type of color variations that appear in the panel
Choose one of the following variations from the Color Guide panel menu:

Show Tints/Shades Adds black to variations on the left and white to variations on the right

Show Warm/Cool Adds red to variations on the left and blue to variations on the right

http://helpx.adobe.com/en/illustrator/using/using-creating-swatches.html#group_swatches
http://helpx.adobe.com/en/illustrator/using/create-color-themes-kuler.html#create_color_themes_with_kuler
http://www.adobe.com/go/vid0058
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Chapter 7: Painting

About painting
To help you add visual interest to your artwork, Adobe Illustrator provides calligraphic, scatter, art, pattern, and bristle 
brushes. In addition, you can use the Live Paint feature and Shape Builder tools, to paint different path segments and 
fill enclosed paths with different colors, patterns, or gradients. Using the Shape Builder tool, you can create new 
complex new shapes by merging simple shapes. Using opacity, masks, gradients, blends, meshes, and patterns provides 
limitless opportunities for creativity. The Width tool provides the ability to create strokes with variable width that make 
very articulate outlines.

More Help topics 
Painting with fills and strokes

Live Paint groups

Brushes

Transparency and blending modes

Gradients

Meshes

Patterns

Paint with fills and strokes

Painting methods
Illustrator provides two methods of painting:

• Assigning a fill, stroke, or both to an entire object

• Converting the object to a Live Paint group and assigning fills or strokes to the separate edges and faces of paths
within it

Paint an object

After you draw an object, you assign a fill, stroke, or both to it. You can then draw other objects that you can paint 
similarly, layering each new object on top of the previous ones. The result is something like a collage made out of shapes 
cut from colored paper, with the look of the artwork depending on which objects are on top in the stack of layered 
objects.

For a video on using brushes, see Use Brushes.

http://helpx.adobe.com/en/illustrator/using/painting-fills-strokes.html#painting_with_fills_and_strokes
http://helpx.adobe.com/en/illustrator/using/live-paint-groups.html#live_paint_groups
http://helpx.adobe.com/en/illustrator/using/brushes.html#brushes
http://helpx.adobe.com/en/illustrator/using/transparency-blending-modes.html#transparency_and_blending_modes
http://helpx.adobe.com/en/illustrator/using/gradients.html#gradients
http://helpx.adobe.com/en/illustrator/using/meshes.html#meshes
http://helpx.adobe.com/en/illustrator/using/patterns.html#patterns
https://helpx.adobe.com/illustrator/how-to/use-brushes.html
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Paint a Live Paint group

With the Live Paint method, you paint more like you would with a traditional coloring tool, without regard to layers or 
stacking order, which can make for a more natural workflow. All objects in a Live Paint group are treated as if they are 
part of the same flat surface. This means you can draw several paths and then color separately each area enclosed by 
these paths (called a face). You can also assign different stroke colors and weights to portions of a path between 
intersections (called an edge). The result is that, much like a coloring book, you can fill each face and stroke each edge 
with a different color. As you move and reshape paths in a Live Paint group, the faces and edges automatically adjust in 
response.

For a video on using Live Paint, see Live Paint.

About fills and strokes
A fill is a color, pattern, or gradient inside an object. You can apply fills to open and closed objects and to faces of Live 
Paint groups.

A stroke can be the visible outline of an object, a path, or the edge of a Live Paint group. You can control the width and 
color of a stroke. You can also create dashed strokes using Path options, and paint stylized strokes using brushes.

Note: When working with Live Paint groups, you can apply a brush to an edge only if you add a stroke to the group 
using the Appearance panel.

The current fill and stroke colors appear in the Tools panel.

https://helpx.adobe.com/illustrator/how-to/illustrator-live-paint.html
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More Help topics 
Keyboard shortcuts for painting objects

Select colors using the Color Picker

Fill and Stroke controls
Controls for setting the fill and stroke are available in the Tools panel, the Control panel, and the Color panel.

Use any of the following controls in the Tools panel to specify color:

Fill button  

Double-click to select a fill color using the Color Picker.

Stroke button  

Double-click to select a stroke color using the Color Picker.

Swap Fill And Stroke button  

Click to swap colors between the fill and stroke.

Default Fill And Stroke button  

Click to return to the default color settings (white fill and black stroke).

Color button  

Click to apply the last-selected solid color to an object with a gradient fill or no stroke or fill.

Gradient button  

Click to change the currently selected fill to the last-selected gradient.

None button  

Click to remove the selected object’s fill or stroke.

You can also specify color and stroke for a selected object by using the following controls in the Control panel:

Fill color Click to open the Swatches panel or Shift-click to open an alternate color mode panel, and choose a color.

Stroke color Click to open the Swatches panel or Shift-click to open an alternate color mode panel, and choose a color.

Stroke panel Click the word Stroke to open the Stroke panel and specify options.

Stroke weight Choose a stroke weight from the pop-up menu.

Apply a fill color to an object
You can apply one color, pattern, or gradient to an entire object, or you can use Live Paint groups and apply different 
colors to different faces within the object.

1 Select the object using the Selection tool ( ) or the Direct Selection tool ( ).

2 Click the Fill box in the Tools panel or the Color panel to indicate that you want to apply a fill rather than a stroke.

http://helpx.adobe.com/en/illustrator/using/default-keyboard-shortcuts.html#keys_for_painting_objects
http://helpx.adobe.com/en/illustrator/using/selecting-colors.html#select_colors_using_the_color_picker
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More Help topics 
About compound paths

Group or ungroup objects

Remove a fill or stroke from an object
1 Select the object.

2 Click the Fill box or the Stroke box in the Tools panel to indicate whether you want to remove the object’s fill or its 
stroke.

3 Click the None button in the Tools panel, the Color panel, or the Swatches panel.

Note: You can also click the None icon in the Fill menu or the Stroke Color menu in the Control panel.

A Fill box  B Stroke box  C None button  

Select objects with the same fill and stroke
You can select objects that have the same attributes, including fill color, stroke color, and stroke weight. 

Note: The Select > Same > Fill Color, Stroke Color, and Stroke Weight commands work within a Live Paint group when 
you select a face or edge with the Live Paint Selection tool. Other Select > Same commands don't work. You can't select the 
same objects both inside and outside a Live Paint group at the same time.

• To select objects with the same fill and stroke, select one of the objects, click the Select Similar Objects button in
the Control panel, and choose what you want to base your selection on in the menu that appears.

• To select all objects with the same fill or stroke color, select an object with that fill or stroke color, or choose the color 
from the Color panel or Swatches panel. Then choose Select > Same and click Fill Color, Stroke Color, or Fill &
Stroke on the submenu.

• To select all objects with the same stroke weight, select an object with that stroke weight or choose the stroke weight 
from the Stroke panel. Then choose Select > Same > Stroke Weight.

• To apply the same selection options using a different object (for example, if you have already selected all red objects 
using the Select > Same > Fill Color command and now you want to search for all green objects), select a new object 
and then choose Select > Reselect.

Tip: To consider the tint of an object when selecting based on color, choose Edit > Preferences > General (Windows) 
or Illustrator > Preferences > General (Mac OS), and then choose Select Same Tint %. Now if you select an object
filled with a 50% tint of PANTONE Yellow C and choose Select > Same > Fill Color, Illustrator selects only those
objects filled with a 50% tint of that color. If you deselect this option, Illustrator selects objects with any tint of
PANTONE Yellow C.

Create multiple fills and strokes
Use the Appearance panel to create multiple fills and strokes for the same object. Adding multiple fills and strokes to 
an object is the basis for creating many interesting effects. For example, you can create a second, narrower stroke on top 
of a wide stroke, or you can apply an effect to one fill but not the other.

1 Select one or more objects or groups (or target a layer in the Layers panel).

http://helpx.adobe.com/en/illustrator/using/combining-objects.html#about_compound_paths
http://helpx.adobe.com/en/illustrator/using/grouping-expanding-objects.html#group_or_ungroup_objects
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• Align Stroke To Outside

Note: If you try to align paths that use different stroke alignments, the paths may not exactly align. Make sure the path 
alignment settings are the same if you need the edges to match up exactly when aligned. 

Create dotted or dashed lines
You can create a dotted or dashed line by editing an object’s stroke attributes.

1 Select the object.

2 In the Stroke panel, select Dashed Line. If the Dashed Line option isn’t showing, choose Show Options from the 
Stroke panel menu.

3 Click the icon: Align Dashes to Corners and Path Ends, Adjusting Length to Fit . This option allows you to 
make the dashes at the corners and ends of the paths consistent and predictable. If you need to retain the appearance 
of the dashes without aligning then select the Preserve exact dash and gap lengths icon.

A Preserved exact dash and gap lengths  B Aligned dashes to corners and path ends, adjusting lengths to fit  

4 Specify a dash sequence by entering the lengths of dashes and the gaps between them.

The numbers entered are repeated in sequence so that once you have established the pattern, you don’t need to fill 
in all the text boxes.

5 Select a cap option to change the ends of the dashes. The Butt Cap option creates square-ended dashes; the Round 
Cap option creates rounded dashes or dots; the Projecting Cap option extends the ends of dashes.

A Butt cap  B Round cap  C Projecting cap  

For a video on creating perfectly dashed strokes, see Creating corner-aligned dashed lines.

http://tv.adobe.com/watch/learn-illustrator-cs5/creating-corneraligned-dashed-lines/
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More Help topics 
Gradient mesh

Apply a gradient to an object

Gradient panel and Gradient tool overview
You can use the Gradient panel (Window > Gradient) or the Gradient tool to apply, create, and modify gradients. 

Gradient colors are defined by a series of stops along the gradient slider. A stop marks the point at which a gradient 
changes from one color to the next, and is identified by a square below the gradient slider. The squares display the color 
currently assigned to each gradient stop. With a radial gradient, the leftmost gradient stop defines the center point’s 
color fill, which radiates outward to the color of the rightmost gradient stop.

Using the options in the Gradient panel or with the Gradient tool, you can specify the number and location of stops, 
angle in which the colors display, aspect ratio of an elliptical gradient, and the opacity of each color. 

Gradient panel

In the Gradient panel, the Gradient Fill box displays the current gradient colors and gradient type. When you click the 
Gradient Fill box, the selected object is filled with the gradient. Directly to the right of this box is the Gradient menu 
that lists all the default and presaved gradients from which you can choose. At the bottom of the list is a Save Gradient 
button that you can click to save the current gradient settings as a swatch. 

By default, the panel includes a start and end color box, but you can add more color boxes by clicking anywhere along 
the gradient slider. Double-clicking a gradient stop opens the gradient stop color panel where you can choose a color 
from the Color panel or Swatches panel.

It’s helpful to show all options when working with the panel (choose Show Options from the panel menu).

A Gradient Fill box  B Gradient menu  C Fill Gradient  D Stroke Gradient  E Reverse Gradient  F Midpoints  G Color Stop  H Opacity  I Location  
J Panel Menu  K Stroke Gradient Type  L Angle  M Aspect Ratio  N Delete Stop  

Gradient tool

http://www.adobe.com/go/learn_ai_tutorials_gradientmesh
http://helpx.adobe.com/illustrator/using/apply-or-edit-gradient.html
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You use the Gradient tool to add or edit gradients. When you click the Gradient tool in an unselected, nongradient filled 
object it fills the object with the last used gradient. The Gradient tool also provides most of the same features as the 
Gradient panel. When you select a gradient filled object and select the Gradient tool, a gradient annotator appears in 
the object. You can use the gradient annotator to modify the angle, location, and spread of a linear gradient or the focal 
point, origin, and spread of a radial gradient. If you position the tool directly over the gradient annotator, it becomes a 
slider (same as in the Gradient panel) with gradient stops and location indicators. You can click the gradient annotator 
to add new gradient stops, double-click individual gradient stops to specify new colors and opacity settings, or drag 
gradient stops to new locations. 

When you position the pointer over the gradient annotator and the rotation cursor appears you can drag to 
reposition the angle of the gradient. Dragging the circular end of the gradient slider repositions the origin of the 
gradient, and dragging the arrow end increases or decreases the range of the gradient.

To hide or show the gradient annotator, choose View > Hide Gradient Annotator or View > Show Gradient Annotator.
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Chapter 8: Selecting and arranging objects

Select objects
To organize and lay out your artwork, you use tools for selecting, positioning, and stacking objects precisely. You can 
measure and align objects; group objects so that they are treated as a single unit; and selectively isolate, lock, or hide 
objects. 

Selection options and preferences

Options for selecting objects
Before you can modify an object, you need to distinguish it from the objects around it. You do that by selecting the 
object. Once you’ve selected an object, or a part of an object, you can edit it.

Illustrator provides the following selection methods and tools:

Isolation mode Lets you quickly isolate a layer, sublayer, path, or group of objects, from all other art in your document. 
When in isolation mode, all nonisolated objects in the document appear dimmed and are not selectable or editable. 

Layers panel Lets you quickly and precisely select individual or multiple objects. You can select a single object (even if 
it’s in a group), all objects within a layer, and entire groups.

Selection tool  Lets you select objects and groups by clicking or dragging over them. You can also select groups 
within groups and objects within groups.

Direct Selection tool  Lets you select individual anchor points or path segments by clicking on them, or select an 
entire path or group by selecting any other spot on the item. You can also select one or more objects in a group of 
objects.

note: When in outline mode, the Direct Selection tool may select imported graphics that are near the tool’s pointer. To avoid 
selecting unwanted graphics, lock or hide the graphics before making the selection.

Group Selection tool  Lets you select an object within a group, a single group within multiple groups, or a set of 
groups within the artwork. Each additional click adds all objects from the next group in the hierarchy. 

Perspective Selection tool Lets you bring objects and text in perspective, switch active planes, move objects in 
perspective, and move objects in perpendicular direction. 

Lasso tool  Lets you select objects, anchor points, or path segments by dragging around all or part of the object. 

Magic Wand tool  Lets you select objects of the same color, stroke weight, stroke color, opacity, or blending mode 
by clicking the object. 

Live Paint Selection tool  Lets you select faces (areas enclosed by paths) and edges (portions of paths between 
intersections) of Live Paint groups. 
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2 In the Reflect dialog box, select the axis across which you want the object to be reflected. You can reflect an object 
across a horizontal, a vertical, or an angled axis.

3 If the object contains patterns and you want to reflect the patterns, select Patterns. (To reflect only the patterns, 
deselect Objects.)

4 To preview the effect before you apply it, select Preview.

5 Do one of the following:

• To reflect the object, click OK.

• To reflect a copy of the object, click Copy.

Layers

About layers
When creating complex artwork, it’s a challenge to keep track of all the items in your document window. Small items 
get hidden under larger items, and selecting artwork becomes difficult. Layers provide a way to manage all the items 
that make up your artwork. Think of layers as clear folders that contain artwork. If you reshuffle the folders, you change 
the stacking order of the items in your artwork. You can move items between folders and create subfolders within 
folders.

The structure of layers in your document can be as simple or complex as you want it to be. By default, all items are 
organized in a single, parent layer. However, you can create new layers and move items into them, or move elements 
from one layer to another at any time. The Layers panel provides an easy way to select, hide, lock, and change the 
appearance attributes of artwork. You can even create template layers, which you can use to trace artwork, and exchange 
layers with Photoshop.

For a video about keeping your artwork flexible and organized by using layers in your document, see Organize artwork 
with layers.

Layers panel overview
You use the Layers panel (Window > Layers) to list, organize, and edit the objects in a document. By default, every new 
document contains one layer, and each object you create is listed under that layer. However, you can create new layers 
and rearrange items to best suit your needs. 

By default, Illustrator assigns a unique color (up to nine colors) to each layer in the Layers panel. The color displays 
next to the layer name in the panel. The same color displays in the illustration window in the bounding box, path, 
anchor points, and center point of a selected object. You can use this color to quickly locate an object’s corresponding 
layer in the Layers panel, and you can change the layer color to suit your needs. 

When an item in the Layers panel contains other items, a triangle appears to the left of the item’s name. Click the 
triangle to show or hide the contents. If no triangle appears, the item contains no additional items.

https://helpx.adobe.com/illustrator/how-to/stay-organized-with-layers.html
https://helpx.adobe.com/illustrator/how-to/stay-organized-with-layers.html
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A Visibility column  B Edit column  C Target column  D Selection column  

The Layers panel provides columns to the left and right of the listings. Click in a column to control the following 
characteristics:

Visibility column Indicates whether items in the layers are visible or hidden (blank space), or whether they are 
template layers or outline layers. 

Edit column Indicates whether items are locked or unlocked. The lock icon indicates that the item is locked and 
cannot be edited; a blank space indicates that the item is unlocked and can be edited.

Target column Indicates whether items are targeted for application of effects and edit attributes in the Appearance 
panel. When the target button appears as a double ring icon (either or ), the item is targeted; a single ring icon 
indicates that the item is not targeted.

Selection column Indicates whether items are selected. A color box appears when an item is selected. If an item, such 
as a layer or group, contains some objects that are selected and other objects that are unselected, a smaller selection 
color box appears next to the parent item. If all of the objects within the parent item are selected, the selection color 
boxes are the same size as the marks that appear next to selected objects.

You can use the Layers panel to display some items as outlines and other items as they will appear in the final artwork. 
You also can dim linked images and bitmap objects to make it easier to edit artwork on top of the image. This is 
especially useful when tracing a bitmap image.
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Distort Linear Gradients Distorts linear gradients along with an object’s shape.

Distort Pattern Fills Distorts patterns along with an object’s shape.

note: If you expand the envelope with a Distort option selected, the respective property is expanded separately.

More Help topics 
Reshaping objects with effects

Combine objects

Methods of combining objects
You can combine vector objects to create shapes in a variety of ways in Illustrator. The resulting paths or shapes differ 
depending on the method you use to combine the objects.

Pathfinder effects

Pathfinder effects let you combine multiple objects using interaction modes. When you use Pathfinder effects, you can’t 
edit the interactions between objects. See .

Compound shapes 

Compound shapes let you combine multiple objects and specify how you want each object to interact with the other 
objects. Compound shapes are more versatile than compound paths because they provide four kinds of interactions: 
add, subtract, intersect, and exclude. In addition, the underlying objects aren't changed, so you can select each object 
within a compound shape to edit it or change its interaction mode. See .

Compound paths

Compound paths let you use an object to cut a hole in another object. For example, you can create a doughnut shape 
from two nested circles. Once you create a compound path, the paths act as grouped objects. You can select and 
manipulate the objects separately using the Direct Selection tool or Group Selection tool; or you can select and edit the 
combined path. See .

Note: You can also add to an object by using the Blob Brush tool. When you use this brush, paths you paint are added to 
adjacent paths that use identical fill attributes. See and Building new shapes using the Shape Builder tool .

Combine objects using Pathfinder effects

Navigate the Pathfinder panel
You use the Pathfinder panel (Window > Pathfinder) to combine objects into new shapes.

http://helpx.adobe.com/en/illustrator/using/reshaping-objects-effects.html#reshaping_objects_with_effects
http://helpx.adobe.com/en/illustrator/using/building-new-shapes-using-shape.html#building_new_shapes_using_the_shape_builder_tool
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Use the top row of buttons in the panel to make paths or compound paths. To make compound shapes, use the buttons 
in those rows while pressing the Alt or Option key. 

Choose from the following shape modes:

Add To Shape Area Adds the area of the component to the underlying geometry. 

Subtract from Shape Area Cuts out the area of the component from the underlying geometry. 

Intersect Shape Areas Uses the area of the component to clip the underlying geometry as a mask would. 

Exclude Overlapping Shape Areas Uses the area of the component to invert the underlying geometry, turning filled 
regions into holes and vice versa.

Use the bottom row of buttons in the panel, called Pathfinder effects, to create final shape combinations on the first 
click. (See .)

A All components in Add mode  B Subtract mode applied to squares  C Intersect mode applied to squares  D Exclude mode applied to squares  

Specify Pathfinder options
Set Pathfinder Options from the Pathfinder panel menu or by double-clicking a Pathfinder effect in the Appearance 
panel.

Precision Affects how precisely the Pathfinder effects calculate an object’s path. The more precise the calculation, the 
more accurate the drawing and the more time is required to generate the resulting path. 

Remove Redundant Points Removes unnecessary points as you click a Pathfinder button. 

Divide And Outline Will Remove Unpainted Artwork Deletes any unfilled objects in the selected artwork as you click 
the Divide or Outline button. 
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Build new shapes with Shaper and Shape Builder tools

About the Shaper Tool
The Shaper tool helps you create complex and beautiful designs by drawing, stacking, and placing shapes 
together, and then simply combining, merging, deleting, or moving them. Use simple, visually-intuitive gestures to 
perform operations that previously may have taken multiple actions to achieve.

Use the Shaper tool to turn natural gestures into vector shapes. Use a mouse or the ease of a touch device to create 
polygons, rectangles, or circles. The shapes drawn are live shapes. This feature is enabled in the traditional workspaces, 
the specialized Touch workspace, and on your mobile with Illustrator Draw.

Using the Shaper tool (drawing shapes)
1 In Illustrator, from the Toolbox, click the Shaper tool (Shift+N).

2 In the document, draw a shape. For example, draw a rough representation of a rectangle, circle, ellipse, or triangle 
or other polygon.

3 The shape you draw is converted into a crisp geometric shape. The shape created is Live, and is fully editable like 
any Live shape. 

Using the Shaper tool (creating shapes)
1 Do one of the following:

• Select a few overlapping shapes in your document

• Use a tool to draw shapes that are overlapping

• Use the Shaper tool (Shift + N) to quickly draw rectangles, circles, or polygons

2 If not already selected, select the Shaper tool (Shift + N).

3 Using your mouse (on a non-touch device) or your finger scribble on an area that you would either like to merge, 
delete, or punch out.
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The following rules determine how portions of the shapes are punched out or merged, and what the color of a 
merged shape is:

• If the scribble is within one shape, the area is punched out.

• If the scribble is across intersecting areas of two or more shapes, the intersecting areas are punched out

• If scribble originates from the shape in the front:

• From a non-overlapping area to an overlapping area, the shape in the front is punched out

• From an overlapping area to a non-overlapping area, the shapes are merged, with the color of the merged area 
being that of the scribble origin point.

• If the scribble originates from the shape in the back:

• From a non-overlapping area to an overlapping area, the shapes are merged, with the color of the merged area
being that of the scribble origin point.

•

Selecting shapes in a Shaper Group
All shapes in a Shaper Group stay editable, even after portions of shapes may have been punched out or merged. The 
following actions allow you to select individual shapes or the group:

Face Selection mode
1 Select the Shaper Tool.
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Enter text at a point
Point type is a horizontal or vertical line of text that begins where you click and expands as you enter characters. Each 
line of text is independent—the line expands or shrinks as you edit it, but doesn’t wrap to the next line. Entering text 
this way is useful for adding a few words to your artwork.

1 Select the Type tool or the Vertical Type tool .

The pointer changes to an I-beam within a dotted box. The small horizontal line near the bottom of the I-beam 
marks the position of the baseline, on which the text rests.

2 (Optional) Set text-formatting options in the Control panel, Character panel, or Paragraph panel.

3 Click where you want the line of text to begin. 

Note: Be sure not to click an existing object, because doing so converts the type object into area type or type on a path. 
If an existing object is located where you want to enter text, lock or hide the object.

4 Enter the text. Press Enter or Return to begin a new line of text within the same type object.

5 When you finish entering text, click the Selection tool to select the type object. Alternatively, Ctrl-click (Windows) 
or Command-click (Mac OS) the text.

Note: For more information about working with type in Illustrator, see this video.

Enter text in an area
Area type (also called paragraph type) uses the boundaries of an object to control the flow of characters, either 
horizontally or vertically. When the text reaches a boundary, it automatically wraps to fit inside the defined area. 
Entering text this way is useful when you want to create one or more paragraphs, such as for a brochure.

1 Define the bounding area:

• Select the Type tool or the Vertical Type tool , and drag diagonally to define a rectangular bounding 
area.

• Draw the object you want to use as the bounding area. (It doesn’t matter if the object has stroke or fill attributes, 
because Illustrator automatically removes them.) Then select the Type tool , the Vertical Type tool , the 
Area Type tool , or the Vertical Area Type tool and click anywhere on the object’s path.

https://helpx.adobe.com/illustrator/how-to/work-with-type.html
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Note: If the object is an open path, you must use the Area Type tool to define the bounding area. Illustrator draws an 
imaginary line between the endpoints of the path to define the boundaries.

2 (Optional) Set text-formatting options in the Control panel, Character panel, or Paragraph panel.

3 Enter the text. Press Enter or Return to begin a new paragraph.

4 When you finish entering text, click the Selection tool to select the type object. Alternatively, Ctrl-click (Windows) 
or Command-click (Mac OS) the text.

If you enter more text than can fit within an area, a small box containing a plus symbol (+) appears near the bottom 
of the bounding area. 

You can resize the text area or extend the path to display the overflow text. You can also thread the text into another 
object.

Note: For more information about working with type in Illustrator, see this video.

Manage the text area

Resize a text area
You can resize text in different ways, depending on the whether you are creating point type, area type, or text along a 
path. 

There is no limit for the amount of text that can be written using point type, so resizing of the text box is not required 
in this case.

When using the area type tool, you drag an object and type inside the selected area. In this case, the text resizes when 
you resize the object using the Direct Selection tool.

When you type text along a path, you can thread text between objects (see Threading text between objects), if the text 
does not fit in the selected path. In this case also, the text is resized if you resize the path using the Direct Selection tool.

Make sure that the bounding box setting is set to Show Bounding Box. If you are not able to see the bounding box, then 
click View > Show Bounding Box.

To resize, do one of the following:

• Select the type object using the Selection tool or Layers panel, and drag a handle on the bounding box.

https://helpx.adobe.com/illustrator/how-to/work-with-type.html
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Align type to object
To align text according to the bounding box of the actual glyphs instead of the font metrics, do the following: 

1 Apply the Outline Object live effect to the text object using Effect > Path > Outline Object.

2 Set the Align panel to use preview bounds by selecting the Use Preview Bounds option from the Align panel menu 
(flyout).

After applying these settings, you get exactly the same alignment as outlined text, while keeping the text live.

Delete empty type objects from your artwork
Deleting unused type objects makes your artwork easier to print and reduces the file size. You can create empty type 
objects, for example, if you inadvertently click the Type tool in the artwork area and then choose another tool. 

1 Choose Object > Path > Clean Up.

2 Select Empty Text Paths, and click OK.

Create type on a path
Type on a path flows along the edge of an open or a closed path. When you enter text horizontally, the characters are 
parallel to the baseline. When you enter text vertically, the characters that are perpendicular to the baseline. In either 
case, the text flows in the direction in which points were added to the path.

Enter text on a path
1 Do one of the following:

• To create horizontal text along a path, select the Type tool or the Type On A Path tool . 

• To create vertical text along a path, select the Vertical type tool or the Vertical Type On A Path tool . 

2 (Optional) Set text-formatting options in the Control panel, Character panel, or Paragraph panel.

3 Position the pointer on the path, and click. (It doesn’t matter if the path has stroke or fill attributes, because 
Illustrator automatically removes them.)

Note: If the path is closed, rather than open, you must use the Type On A Path tool.

4 Enter the text.

5 When you finish entering text, click the Selection tool to select the type object. Alternatively, Ctrl-click (Windows) 
or Command-click (Mac OS) the text.

If you enter more text than can fit within an area or along a path, a small box containing a plus symbol (+) appears near 
the bottom of the bounding area. 
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You can resize the text area or extend the path to display the overflow text. You can also thread the text into another 
object.

For a video on creating type on a path, see Put type on a path.

Move or flip text along a path
1 Select the path type object.

A bracket appears at the beginning of the type, at the end of the path, and at the midpoint between the start and end 
brackets. 

2 Position the pointer over the type’s center bracket until a small icon appears next to the pointer .

3 Do one of the following:

• To move text along the path, drag the center bracket along the path. Hold down Ctrl (Windows) or Command
(Mac OS) to prevent the type from flipping to the other side of the path.

• To flip the direction of text along a path, drag the bracket across the path. Alternatively, choose Type > Type On 
A Path > Type On A Path Options, select Flip, and click OK.

https://helpx.adobe.com/illustrator/how-to/illustrator-putting-type-on-path.html
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Tip: To move type across a path without changing the direction of the type, use the Baseline Shift option in the 
Character panel. For example, if you created type that runs from left to right across the top of a circle, you can enter 

a negative number in the Baseline Shift text box to drop the type so that it flows inside the top of the circle.For a video 
on creating type on a path, see Put type on a path. 

More Help topics 
Shift the baseline

Apply effects to type on a path
Path type effects let you distort the orientation of characters on a path. You must first create type on a path before you 
can apply these effects. 

1 Select the path type object.

2 Do one of the following:

• Choose Type > Type On A Path and select an effect from the submenu.

• Choose Type > Type On A Path > Type On A Path Options. Then select an option from the Effect menu, and
click OK.

Note: Applying the Gravity effect to text on a perfectly circular path creates a result that looks like the default
Rainbow effect. It performs as expected on paths that are oval, square, rectangular or otherwise irregularly
shaped.

https://helpx.adobe.com/illustrator/how-to/illustrator-putting-type-on-path.html
http://helpx.adobe.com/en/illustrator/using/line-character-spacing.html#shift_the_baseline
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A Font  B Font Style  C Font Size  D Kerning  E Horizontal Scale  F Baseline Shift  G Leading  H Tracking  I Vertical Scale  J Character Rotation  
K Language  

A Font  B Font Style  C Font Size  D Align left  E Align center  F Align right  

By default, only the most commonly used options are visible in the Character panel. To show all options, choose Show 
Options from the options menu. Alternatively, click the double triangle on the panel’s tab to cycle through the display 
sizes.

More Help topics 
Character and paragraph styles

Underline or strike through text
1 Select the type you want to underline or strike through. If you don’t select any text, the setting applies to new text 

you create.

2 Do one of the following:

• To underline type, click the Underline button in the Character panel.

• To strike through type, click the Strikethrough button in the Character panel.

The default weight of an underline and strikethrough depends on the size of the type.

Apply all caps and small caps
When you format text as small caps, Illustrator automatically uses the small-cap characters designed as part of the font, 
if available. Otherwise, Illustrator synthesizes the small caps using scaled-down versions of the regular capital letters.

https://helpx.adobe.com/illustrator/using/character-paragraph-styles.html

